Problema de conexión sensor inductivo

QuestionsCategoria: ElectrónicaProblema de conexión sensor inductivo
huelva3d preguntada 2 years antes

Buenas tardes tengo un problema para conectar el sensor de inductivo PNP y es que no dispongo de las conexiones ni conocimiento para su conexión a la placa.
Podrías indicarme cuál es su esquema de conexión y si hay que modificar algo en el firmware

Gracias

1 Respuestas
diegotrap Staff contestada 2 years antes

Conexión a la placa

Primero hay que conectar correctamente el hardware a la placa. Nosotros usamos un diodo con el sensor inductivo para que la tensión de alimentación de 12V no dañe la placa, que puede soportar 5V. El esquema de conexión es el siguiente (los colores de los cables son los de nuestro sensor y también los de la mayoría de los que se usan, pero mira antes que coincidan con los del tuyo):

Selection_003

Teniendo en cuenta que:

  • El cable marrón debe ir conectado a +12V (se obtienen de la salida 12V-aux en la placa RAMPS)
  • El cable azul va conectado a tierra (de la salida 12V-aux de la RAMPS)
  • El diodo, nosotros usamos un LN4148, valen muchas otras referencias (que soporten 12V o más).
  • El cátodo del diodo (lado marcado con la raya) va conectado a la salida del sensor
  • El ánodo del diodo (lado sin marcar con raya) va conectado a la entrada de señal (marcada con una S) del endstop min del eje Z.

Los pines de la placa RAMPS de los que hemos hablado son los que aparecen marcados en la siguiente imagen:

2bae425b-d908-4032-8c32-d9a83151157b

 

Firmware

Si ya tienes conectado correctamente el sensor y tienes un comportamiento extraño al intentar hacer autoleveling, el problema puede estar en el hardware. Para diagnosticarlo puedes usar el comando M119 (get endstop status) y ver si tus endstops (fijándote en el endstop min del eje z, es decir en el sensor de autolevel) se activan correctamente.

En este caso, lo más probable es que tengas el sensor invertido, tienes que configurarlo en la siguiente línea del archivo Configuration.h de Marlin (línea 344 en nuestro actual firmware):

Selection_004

Según tengas un sensor PNP o NPN (lo puedes ver en la etiqueta) elige la opción correspondiente según se indica en el comentario.

Más información

Con esto se deberían arreglar la mayoría de los problemas de conexión y configuración del sensor inductivo, si mecesitas más ayuda estamos a tu disposición.

huelva3d contestada 2 years antes

Gracias por la explicación tan grafica, ya tengo todo funcionando perfectamente