Z motor won’t stop on initial G28 command

QuestionsCategory: Printing and calibrationZ motor won’t stop on initial G28 command
ASAF PELED asked 1 year ago

I am setting up my printer for the first time. Following instructions on the website I issued a G28 command in CURA. The Y and X motors seemed to move then stop at a certain point then the Z motor moved the extruder up until which point it hits the top against the filament feed motor and continues to try and advance, causing clicking sounds and won’t stop. I had to unplug the printer to stop it.

1 Answers
diegotrap Staff answered 1 year ago

This behaviour could be that the printer is trying to home the Z axis by going upwards instead of going down until it finds the bed. Check the following things to ensure that it is homing in the right direction and all the components are working well:

  • When you send a new G28 command, make sure that the carriage is around the middle of the Z axis, since it will go up a bit (5 or 10 mm) before starting to go down to find the printing surface.
  • The Z motor cable is connected like shown in the wiring diagram: http://mprime.io/m-prime-one-wiring-guide/. The black wire should be the nearest to the USB and power supply connector side of the board. If this connector is reversed the axis direction will be reversed too.
  • Check that the motor wires, in the black connector side, follow the sequence black-red-green-blue, since some of the cables that we shipped were wrongly wired.
  • Check that your Z probe is working: when you put a metallic object near the tip the LED on the top should turn off.
  • Check that the Z probe is properly connected to the board and that the electronics are receiving the signal.
    • First, check that the probe is connected as it is shown in the wiring diagram, and that all the cables are in the correct sequence.
    • Second, send a M119 command to your printer to check if the Z endstop is in the OPEN state when inactive, and in  TRIGGERED state when you put a metal object near the tip.